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SMART Notebook Software Training for SMART Board Users Level 2 Learner Workbook
Best practices 
and tools
How can I  design ef fect ive and 
interact ive lesson act iv i t ies using 
SMART Notebook software?

Many tools are available for creating professional looking interactive lesson activities using 
SMART Notebook collaborative learning software. The SMART Exchange™online community 
enables you to download lessons and collaborate with peers.
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Best practices and tools
Tips for designing effective lesson activities using 
SMART Notebook software

1  Include Teachers’ notes and lesson 
notes at the beginning of every 
lesson activity
Documenting learning objectives and 
key lesson details will help you focus 
your lesson activity during both design 
and delivery. It also provides a clear 
overview of the lesson to others who 
may use the file.

2  Use links to improve the flow of 
a lesson
You can significantly improve the flow 
and organization of your lesson by 
taking advantage of the linking 
capabilities in SMART Notebook 
software. You can link any object on a SMART Notebook page to a webpage, an external 
file, an attached document or another page in the same file.

3  Attach supporting files to your SMART Notebook software file before class
Taking time during a lesson to navigate to files you want to show can be awkward and 
distracting. Your lesson can lose its momentum and students can lose their focus. To avoid 
this, attach files, shortcuts and Internet links to the Attachments tab of your SMART 
Notebook file. You can then open them with a single press. Everyone remains on track, and 
no time is wasted.

4  Use a consistent layout for lesson pages
Using a consistent layout for SMART Notebook pages helps your students know where to 
look for information and keeps them focused on important content. SMART Notebook 
software includes several themes that you can use as templates, or you can create your own 
incorporating school colors, logos and other objects.
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5  Create lessons that fully involve 
learners
The SMART Board™ interactive whiteboard 
is more than a teaching tool: it’s a learning 
tool. Students can use the interactive 
whiteboard to manipulate objects, complete 
activities, make notes during brainstorming 
sessions and deliver presentations.

6  Use the Internet and extra resources to 
encourage inquiry
Store links to relevant websites and 
additional resources as attachments in your 
SMART Notebook file. When students are 
particularly interested in a topic or have a 
question, these links can serve as a starting point for inquiry. Consider planning virtual field 
trips, or having the class compose an e-mail to an expert, an author, or another class with a 
question or idea about the interactive whiteboard.
 

7  Engage a variety of learning 
styles 
SMART Notebook software includes 
several tools that enable you to 
tailor lessons to a variety of learning 
preferences. Auditory learners will 
appreciate the sound capabilities. 
Kinesthetic learners will benefit from 
manipulating Flash® activities. 
Visual learners will benefit from the 
rich Gallery collection included with 
SMART Notebook software, as well 
as from watching processes 
recorded using the Page Recorder or SMART Recorder.

8  Record processes, instructions or examples to provide further instruction 
when needed
SMART Notebook software includes a Page Recorder that enables you to record all actions 
on a SMART Notebook page. Consider recording a process or example to be played during 
class if students need additional clarification on a concept.
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Best practices and tools
9  Seek lesson activities on the Internet
Begin by searching the SMART Exchange™  
online community, which offers hundreds of 
ready-made lesson activities and resources. 
Download and modify lesson activities to suit 
the needs of your students.
                                
10  Collaborate and share resources
Keep in regular contact with other educators 
who are using a SMART Board interactive 
whiteboard. Share experiences, ideas, 
challenges, lesson activities and solutions.
4



SMART Notebook Software Training for SMART Board Users Level 2 Learner Workbook
Notes and ideas for designing effective lesson activities 

Use this page to write notes and ideas from the training session discussions.

TIP: One of the quickest ways to add interactivity to a lesson is with a reveal activity, where the 
answer to a question is hidden on the SMART Notebook page. A great way to do this is using 
erase and reveal. 

Type your question and answer, and then use a pen tool to cover the answer with digital ink. 
Select the digital ink, and set it to the same color as the page background. For example, if the 
page background is white, then the digital ink should also be white. To reveal the answer during 
your lesson, select the Eraser tool, and erase the digital ink covering the answer. 
 5



Best practices and tools
The SMART Exchange online community
The SMART Exchange is a repository for a variety of high-quality, peer-reviewed digital content you 
can use with your classroom technology. You’ll find thousands of resources, including standards-
correlated lessons for SMART Notebook collaborative learning software, question sets for 
SMART Response™ interactive response systems, links and other multimedia content. You can 
search for and browse content quickly and easily by subject, grade, curriculum, media type and 
popularity. You can also filter results according to the SMART products you have in your classroom.

Downloading resources
You can search for and download a variety of resources to use with the SMART Board interactive 
whiteboard.

Type a keyword into the Search box and click the search button. 

Resources specific to your region appear. You can narrow your search results by type, subject or 
grade. Click the Search button again to search within the narrowed criteria.

Search button

Click to select your 
region, search in a 
different language or 
within a different 
collection of 
resources.

Select a subject or grade and click Search
to narrow your results.

Click to preview a resource in more detail before 
downloading it.

Click a
resource type

to narrow
your search

results.
Search results
6
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Sharing resources
Contribute to the SMART Exchange community by sharing the resources that you’ve created with 
other teachers. Simply click Share a Resource on the SMART Exchange menu bar and fill out the 
required fields to share a resource you’ve created.

You can also use this area to recommend web pages that you love to use with your SMART Board 
interactive whiteboard. You do not need to own or have created a web page in order to share a link 
to it.

Finding standards-correlated lessons
In many regions, you can search for resources that have been correlated to your local curriculum 
standards. If this service is available for your region, you will see a Standards-Correlated Lessons 
button on the SMART Exchange menu bar.

Click the Standards-Correlated Lessons button and select a standard, grade and subject. Click 
View to display the standards for that region. If a resource is available for a standard, a View 
Resources button displays beside the standard. Click the View Resources button to display the 
correlated resources for that standard.

Connecting with other teachers
The SMART Exchange also features an online teacher community where you can connect with 
colleagues to exchange ideas, insights and classroom success stories. To access the forum, click 
the Connect with Teachers button on the SMART Exchange menu bar.

Anyone can read postings on the forum, 
however to contribute to the forum you need 
to register or sign in to the SMART 
Exchange. 

To register, click the Join link in the top-right 
corner of the Connect with Teachers area. 
After registering you can sign in to gain full access to the forum. 

Conversations, or threads, are sorted into categories and each of the categories is subdivided. To 
view the threads in a category, or to open a specific thread, click the title. 
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Review: Best practices and tools
  1  List three tips for designing effective lesson activities in SMART Notebook software.

  2  From which website can you download SMART-created lesson activities?

  3  Describe two of the areas in the SMART Exchange.
 9



Best practices and tools Q and A
Review: Best practices and tools
  1  List three tips for designing effective lesson activities in SMART Notebook software.

•  Include Teachers’ notes and lesson notes at the beginning of every lesson activity
•  Use links to improve the flow of a lesson
•  Attach supporting files to your SMART Notebook software file before class
•  Use a consistent layout for lesson pages
•  Create lessons that are hands-on for learners
•  Use the Internet and extra resources to encourage inquiry
•  Engage a variety of learning styles in each lesson activity
•  Record processes, instructions or examples to provide further instruction when needed
•  Seek lesson activities on the Internet
•  Collaborate and share resources with others

  2  From which website can you download SMART-created lesson activities?
         http://exchange.smarttech.com

  3   Describe two of the areas in the SMART Exchange.
•  Home / Search – Search for and download lessons, images, web pages and more.
•  Share a Resource – Share resources and web page addresses
•  Standards-Correlated Lessons (available in some regions only) – Download resources 
that are aligned to your regional standards
•  Connect with Teachers – Online forum for sharing ideas and resources
10
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Structuring and 
organizing lessons
How can I  make my SMART 
Notebook f i les organized and 
easy to use?

The Page Grouping feature in SMART Notebook software enables you to organize pages. Links, 
buttons and attachments can help you improve the flow of a lesson activity. Additional features, 
such as My Content and team content, help you keep your learning objects and SMART Notebook 
files well organized.
 11



Structuring and organizing lessons
The Lesson Activity Toolkit
The Lesson Activity Toolkit is a Gallery collection full of ready-to-use content. It provides many tools 
and resources that can be helpful when preparing and delivering a lesson. 

You have the option of installing the Lesson Activity Toolkit when installing SMART Notebook 
software 10. However, if you did not install it at that time, you can download it by checking for 
updates.

To install or update the Lesson Activity Toolkit:

  1  Click the Show additional Gallery actions button in the Gallery tab
  2  Select Check for Updates > Lesson Activity Toolkit. The Lesson Activity Toolkit update wizard 

appears.
  3  Follow the prompts to install or update the Toolkit

Show additional Gallery actions button
12
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Lesson Activity Toolkit contents
When installed, the Lesson Activity Toolkit will appear as a folder in the Gallery. It has the following 
six subfolders:

Activities – Activity templates are Flash®-created objects that make it easy for you to create sorting, 
matching and other interactive lesson activities. 

Examples – The Examples folder includes filled-in content from the Activities, Pages, and Tools 
folders. These demonstrate the many dynamic and fun ways that SMART Notebook can help you 
bring your lessons to life. Many examples include instructional videos that will tell you how to create 
them.

Games – The Games folder contains classic game objects like cards, game boards, and playing 
pieces.

Graphics –  Graphics help give your lessons a more professional look with its array of icons, 
borders, labels, and pull tabs.

Pages – Pre-made pages save you time and effort when creating title pages, questions, and other 
lesson pages. Its contents are similar to those of the Activities folder, but are fully made of SMART 
Notebook objects and are more cutomizable than Activities.

Tools – Tools are Flash-created objects that perform a variety of actions from animated answer 
revealers,  randomizers, and timers.
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Structuring and organizing lessons
Title pages and lesson pages
Ready-made pages make it easier for you to add structure and style to your lessons. You can find 
templates for title pages and lesson pages – complete with title bars – in the Pages folder of the 
Lesson Activity Toolkit.

To add one of these templates to your lesson, drag and drop it onto any page of the SMART 
Notebook file, then fill out the pages to suit your lesson activity. To change the text on the pages 
and title bars, highlight the existing text and start typing.

Title pages
Just as you would ask your students to include a title page on a book report, lab report or research 
project so that you know which student and class it’s for, it’s a good idea to include key details at 
the beginning of any SMART Notebook software lesson activity you create or use. 

Documenting the subject, topic, grade level and learning outcomes at the beginning of your SMART 
Notebook file will help you to focus your efforts on these ideas as you develop the lesson and easily 
find appropriate lesson activities when reusing your files in future years. It will also make it easier 
for others to get an overview of the lesson if you share your resources. 

Lesson objectives
Insert the topic and learning 
objectives to provide an 
overview of the lesson 
activity.

These buttons provide easy 
links between the pages.
14
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Teachers’ notes
Use this page to detail 
information about the lesson 
such as topic or title. This 
action will be useful when 
you are sharing or revising 
the lesson activity. 

Lesson notes
Use this page to document 
comments and instructions 
for the lesson. You can also 
use this page during a 
lesson to keep track of 
student questions or 
improvements you would 
like to make to the lesson 
activity.
 15



Structuring and organizing lessons
Page grouping
To keep your SMART Notebook files well organized, you can sort pages into groups. This is 
particularly useful when there are a large number of pages within a file. Page grouping enables you 
to view your pages in an organized way. You can choose to show or hide specific groups, reducing 
the number of pages visible at a time. You can also rearrange the order of groups, quickly navigate 
to a particular group within the Page Sorter and apply a theme to all the pages within a group. 

As a default, each SMART Notebook file has only one group. You can add and modify groups at 
any time. To view and edit groups, complete the following steps:

  1  Open the Page Sorter tab
  2  Press the Groups button
  3  Select Edit Groups. If you have not yet edited the groups in the SMART Notebook file, all 

pages will be in the default group – Group 1. If you have already edited the groups for this file, 
the pages are displayed under the appropriate title bars.

Press to 
close the 
Groups 
view.

Press the 
Group 
drop-down 
menu to 
rename, 
move or 
delete a 
group.

Press to
create a

new group.

Each group
is identified

with a title
bar.

Press the
collapse
button to
hide the

pages in a
group.
16
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To create a new group, complete the following steps:

  1  Press the Add New Group button. A new group title bar appears and a new blank page 
appears below it. Every group must include at least one page.

  2  Press the group drop-down arrow and select Rename Group
  3  Type a new name for the group

Pages and groups can easily be 
organized using the drag and drop 
method. To move a page to a 
different group or a different 
location in the same group, simply 
drag the thumbnail image for the 
SMART Notebook page to the new 
desired location. To rearrange the 
order of groups, drag a group’s title 
bar to the new location. 
Alternatively, press the group drop-
down menu and select Move Up or 
Move Down.

To delete a group, select Delete 
Group from the drop-down menu. 
When you delete a group, you also 
delete all pages within that group, 
so be sure to move any pages you 
would like to keep into a different group first. If you move all pages out of a group, the group 
disappears automatically.

To close the Groups view, press the Close button in the upper-right corner, or double-click on any 
thumbnail image to navigate directly to that SMART Notebook page.

To move a page to a different location, within the same group or in a different 
group, drag it to the desired location. You can also change the order of 
groups using this method.
 17



Structuring and organizing lessons
When using the Page Sorter, you can navigate 
between groups easily without opening the 
Groups view. To do this, press the Groups 
button at the top of the Page Sorter, and select 
the group you would like to see from the drop-
down list that appears.

Select the
group you

would like to
see from the

drop-down list.

The selected
group, in this

case, the
Answers

 group, will
appear in the
Page Sorter.
18
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Linking
You can significantly improve the flow and organization of your lesson by taking advantage of the 
linking capabilities in SMART Notebook software. You can link any object on a SMART Notebook 
page to a webpage, an external file, an attached item or another page in the same SMART 
Notebook file. 

The ability to link to another page within the SMART Notebook file enables you to move between 
pages quickly, without using the Page Sorter. Since any object can be linked, you can create 
objects that serve as navigation buttons or set different messages to appear based on which object 
you or a student touches on the SMART Notebook page. 

Many teachers like to write congratulatory messages or hints on specific pages, providing students 
with immediate feedback when they touch an object linked to that page. Navigation buttons created 
with links found on the message pages allow students to return to the activity easily to try again or 
move on to the next activity.

To respond to the question, the 
student presses the object that 
he believes causes acid rain. 
All three objects are linked to 
answer pages. within the 
SMART Notebook file. After 
pressing an object, the student 
will be presented with one of 
the two pages shown below.
 19



Structuring and organizing lessons
Tips for keeping your linked file organized
To keep your SMART Notebook file well organized, create the required SMART Notebook pages 
before creating the links. Place all answer pages at the back of the SMART Notebook file, and 
separate them from the lesson activity with a title page. The title page will prevent you from 
inadvertently displaying the answer pages to your students. 

Name each page with a unique, short and descriptive name 
to make the pages easy to identify when you are creating 
the links.

To rename a page, select Rename Page from the page 
drop-down menu in the Page Sorter. Type the page name 
in the text box that appears.
20
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Creating links

To link an object to another page 
within the same SMART 
Notebook file, select Link from 
the object’s drop-down menu, 
and select Page in this File from 
the Insert Link dialog box. 

A list of the pages in the current 
SMART Notebook file will 
appear. Select the page you 
would like to link to. The Page 
Preview pane enables you to 
confirm your selection before 
creating the link.

Select whether you would like to launch the link by clicking Corner icon or Object. 

Press OK to create the link.

In this example, pressing anywhere on the object will link to the page Answer Yes, indicating that 
the object does contribute to acid rain. Brief but descriptive page names make it easy to select the 

correct SMART Notebook page for the link, and the Page Preview pane confirms the selection.
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Structuring and organizing lessons
Show All Links 
If you’re working with a SMART Notebook file that contains 
many links that you have not recently used or that someone 
else created, you can use the Show All Links feature to be sure 
that you have not overlooked any links that are hidden by 
surrounding objects. 

Show All Links briefly highlights all objects on a SMART 
Notebook page that are linked to a website, file, another 
SMART Notebook page or a sound with an animated box. 
Select View > Show All Links to identify the links on the 
current page once, or select View > Show All Links When 
Page Opens to highlight the links each time you open the page 
during the current session.

An animated box appears 
to highlight each link on 
the page.
22
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Attachments
Taking time during a class to navigate to the files you want to show can be awkward and distracting. 
Your lesson can lose its momentum and students can lose their focus. To avoid this situation, attach 
files, shortcuts to files and Internet links to the Attachments tab of your SMART Notebook file and 
open them easily during your lesson. You can then open them with a single press. Everyone 
remains on track, and no time is wasted. Attachments give you ready access to the information you 
want to display.

Attaching a copy of a file
You can add a copy of a file to the Attachments tab. This 
step enables you to keep all resources for a lesson in one 
place, making organizing your electronic files much 
easier. However, when you attach a file, the size of the 
SMART Notebook file increases.

To add a copy of a file to the Attachments tab, do the 
following:

  1  Press the Insert button on the Attachments tab
  2  Select Insert Copy of File
  3  Navigate to and select the file you would like to add 

and press the Open button

When you open the file from the Attachments tab, it will be 
in read-only format. If you would like to save changes to a 
file stored in the Attachments tab, use Save As.

Attach supporting lesson files to a 
SMART Notebook file to save time 
and improve lesson flow.
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Structuring and organizing lessons
Attaching a hyperlink
To save time finding Internet resources and reduce distractions during your lesson, you can add 
hyperlinks to the Attachments tab, similar to saving bookmarks or favorites in your Web browser. 

To add a hyperlink to the Attachments tab, do the following:

  1  Press the Insert button on the Attachments tab
  2  Select Insert Hyperlink
  3  Type the hyperlink address into the Hyperlink field
  4  Type the text you would like to see in the Attachments list – for example, the website name – 

into the Display name field
  5  Press OK
The hyperlink appears in the Attachments tab. To open the webpage in your default browser, 
double-press the link.

Attaching a shortcut to a file
A shortcut is a link to a file that is stored outside of SMART Notebook software. To add the shortcut 
to a file in the Attachments tab, do the following:

  1  Press the Insert button on the Attachments tab
  2  Select Insert Shortcut To File
  3  Navigate to and select the file you would like to add and press the Open button
24
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My Content
You can add your own images, objects and entire SMART Notebook pages to the Gallery, or save 
your favorite items into an easy-to-find location using the My Content folder. My Content is a Gallery 
collection reserved specifically for objects you have imported, captured or created. If there are any 
templates or tools that you use on a regular basis, such as your school logo or a lesson template, 
you can save time and reduce extra work by adding them to your My Content folder.

Adding items to My Content
To add an item to the My Content area, drag the item 
from the work area, the Page Sorter or the Gallery to the 
My Content folder in the Gallery. 

To import additional files from your computer, including 
pictures you have taken with a digital camera or 
downloaded from the Internet, follow these steps:

  1  Select the Gallery Actions icon to the right of the 
search button

  2  Select Add Other Files to My Content to launch 
the Add to My Content... dialog box

  3  Browse to and select the file you would like to add
  4  Press the Open button. Your file will appear as a 

thumbnail in the My Content area of the Gallery.

Organizing My Content
Within the My Content folder, you can create your own 
folders and subfolders to organize your Gallery content 
any way you like. 

To add a subfolder to My Content, do the following:

  1  Select the My Content menu arrow or a subfolder 
menu arrow

  2  Select New Folder. A new folder will appear. 
  3  Type a name for this folder

Adding keywords to objects in the My Content area

Create subfolders within My Content to organize 
learning objects according to grade or class.
 25



Structuring and organizing lessons
The search function in the Gallery works by scanning keywords associated with each Gallery item. 
When you add an item to the My Content area of the Gallery, you can provide keywords to the item 
so it is recognized by the search function and appears in future search results.

To add keywords to a My Content item, do the following:

  1  Press the item’s thumbnail in the My Content area
  2  Press the drop-down menu arrow
  3  Select Properties to launch the Gallery Item Properties dialog box
  4  Type the keywords you would like associated with the item. For example, you could type 

editing and symbol if the Gallery item is an editing symbol you frequently use
  5  Press OK
26
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Team content
You can save time and encourage teamwork by sharing lesson activities with other teachers in your 
school or district. If you are using the same computer network, you can save your lesson activities, 
SMART Notebook files, Gallery Collections, images and multimedia files in a shared team content 
folder on the network. Multiple users can connect to the same content location, and changes made 
by one user are automatically updated for the other users.

A team content folder can be created by your network administrator.

To connect to your team content folder, select the Gallery Actions icon to the right of the search 
button, then select Connect to Team Content. Follow the prompts to locate your team content 
folder. 

To copy files to a team content folder, select and drag files or objects from the My Content area of 
the Gallery to the team content folder. If you want to save your own changes or access the files 
when you are not connected to the network, copy the files from the team content folder to your My 
Content folder.

You can select and drag the Spelling folder from the My 
Content area into the Humanities Team team content folder.

The entire Spelling folder now exists as a subfolder in a 
team content folder called Humanities Team and is 
accessible by others through the network.

The Gallery Actions icon.
 27



Structuring and organizing lessons
Since multiple users can connect to the 
team content folder to add, update or 
delete content, select Refresh from the 
drop-down menu to ensure that you are 
always seeing the most 
up-to-date content.

To disconnect from a team content 
folder, select Disconnect from the drop-
down menu. You can skip this step to 
have the folder appear in the Gallery 
window the next time you open SMART 
Notebook software.

Click the team content drop-down menu to refresh content in 
the team content folder or disconnect from the network.
28
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Review: Structuring and organizing lessons
  1  List two ways to use links to improve the structure and organization of a lesson activity.

  2  How do you turn on the Show All Links When Page Opens setting?

  3  How do you move a page from one group to another?

  4  What are the three ways you can attach items to a SMART Notebook file?

  5  Why would you add a keyword to an item in the My Content folder?

  6  What is a team content folder?
 29



Structuring and organizing lessons Q and A
Review: Structuring and organizing lessons
  1  List two ways to use links to improve the structure and organization of a lesson activity.

•  Link an object to another SMART Notebook page, eliminating the need to use the 
Page Sorter

•  Link an object to a webpage so that it automatically opens the browser to the correct location
•  Link an object to an attached file to eliminate the need to open the Attachments tab

  2  How do you turn on the Show All Links When Page Opens setting?

Select View > Show All Links When Page Opens to highlight the links each time you 
open the page during the current session.

  3  How do you move a page from one group to another?

Open the Page Sorter, press the Groups button and select Edit groups. To move a page 
to a different group, simply drag the thumbnail image for the SMART Notebook page to 
the new desired location.

  4  What are the three ways you can attach items to a SMART Notebook file?

You can add attachments as files, shortcuts to files and Internet links. 

  5  Why would you add a keyword to an item in the My Content folder?

You can add keywords to items in the My Content folder so that they can be located using 
the Search function in the Gallery.

  6  What is a team content folder?

A team content folder is a shared network folder for storing SMART Notebook files, 
Gallery Collections and other learning objects that can be accessed through the Gallery 
by colleagues using the same network.
30
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Adding style to 
lesson activities
How can I  create 
professional- looking 
lesson act iv i t ies?

SMART Notebook software 10 includes many features to enable you to create lesson activities with 
a professional look. Themes, alignment tools and tables will enable you to create visually appealing 
SMART Notebook files. 
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Adding style to lesson activities
Properties tab
The Properties tab provides easy access to formatting and editing options for a selected object or 
objects on a SMART Notebook page. Many formatting options are accessible through the 
Properties tab, however only those options that are available for the currently selected object will 
be visible at any time. These options may include the following items: 

•  The color, transparency and fill effects of objects
•  The color, thickness and style of lines
•  The font type, size and style of text
•  The animation settings for objects

The Properties tab also includes a Page Recording tool, enabling you to record actions on the 
current SMART Notebook page.

Opening the Properties tab
There are three ways to access the Properties tab:

1  Press the Properties toolbar button
2  Press the Properties tab
3  Select the object, press the object drop-down arrow and select Properties

Changing an object’s properties
To change an object’s properties, select the object(s) and open the Properties tab. You can select 
several objects and change their properties at the same time. Any modifications that you make in 
the Properties tab will be immediately visible on the selected object(s). 

The properties that you are able to modify vary depending on the type of object that is selected. 

Each of these tabs 
contains settings that 
can be modified for 
the currently selected 
object. 

Select a new font from 
the drop-down list. The 
change will be 
immediately visible in 
the selected object.
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Fill effects 
In this section, you can change the transparency and fill effects of an object. Increasing an object’s 
transparency means that the image appears lighter on the page, enabling you to see objects that 
are placed behind it. To change the object’s transparency, drag the slider from solid to more 
transparent.

With many objects you can also change the color and type of fill used in the object. There are four 
available fill types:

  1  Solid fill – Select a color from the color palette to fill the object entirely. To access more color 
options, press the More link. 

  2  Gradient fill – This type of fill changes, in a gradual transition, from one color to another. 
Select a color from each of the two palettes. Select a style (the direction the fill transitions in) 
from the drop-down list. The object will change on a gradient from one to the other.

  3  Pattern fill – This type of fill fills your object with the pattern that you select from the palette. 
You can also select foreground and background colors for your pattern by clicking the 
appropriate links. the palette will adjust using your selected colors, making it easier to choose. 

  4  Image fill – Select image fill to fill your object with an image file you have stored on your 
computer. Press the Browse link to locate your image file. The image file will be imported in 
its original size. If you have large files and would like to be able to see the entire image, 
resize the file using your photo editing software file before using it as a fill.  

TIP: Whenever you are selecting colors, you have the option of using the eyedropper tool. This 
tool enables you to select a color from anywhere on your display and use it as the fill color. To 
use the eyedropper, select the object you would like to modify. Then, press the button. Your 
cursor turns to an eyedropper. Press once where the color is located that you would like to use. 
Your object will be filled with that color.

Solid fill Image fillPattern fillGradient fill
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Line Style
Press the Line Style tab to modify line settings for a line or the outline of an object. Select the color 
and thickness from the palettes provided. Next, select the line style, and start and end styles from 
the drop-down menus.

Text Style
Press the Text Style tab to modify font properties including the font type, size and style. 
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Themes
You can use themes to apply a consistent style to pages or groups of pages in a SMART Notebook 
file. The Gallery includes predefined themes, and you can also create your own. To apply an 
existing theme to a SMART Notebook page or a group of pages, complete the following steps:

1  Open the Gallery tab
2  Select Backgrounds and Themes. The Gallery displays 

thumbnails of the available themes.
3  Select the thumbnail of the theme you want to apply
4  Press the thumbnail’s menu arrow and select Insert in 

Notebook. The Insert Theme dialog box appears.
5  Select which pages you would like to apply the theme to
6  Press OK

NOTE: The main difference between a theme and a background 
is that themes control the formatting of any typed text you add 
to the page. You can identify a background by the folded 
bottom corner of the page thumbnail.

Theme

Background
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Adding style to lesson activities
To create a new theme, complete the following steps:

1  Select Format > Themes > Create Theme
2  Type a name for the theme in the Theme name box
3  Select the text object that appears in the workspace, and modify the text to your desired 

default text style for the theme. This text object will not appear in the completed theme.
4  Modify the workspace to reflect your new theme. You may need to scroll down to set up the 

entire SMART Notebook page. 
  5  Press Save

To delete a theme, right-click on the workspace and select Delete Theme. You can delete a theme 
from an individual page, but you cannot delete the theme from all the pages in a group or a file at 
the same time. To remove a theme from all pages at once, apply a Blank theme.

Add objects to the workspace as if it were a SMART Notebook page. You can set a default font by modifying 
the text object that appears in the workspace. When finished, press the Save button.
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Active alignment
When arranging objects on a SMART Notebook page, you may want to align objects to increase 
clarity of your page. SMART Notebook software can display guides on the page to assist you in 
aligning objects with other objects, the page’s vertical center and the page’s horizontal center. 

To display guidelines, select View > Alignment. The 
Alignment Guides dialog box appears.

There are three types of alignment guides available. 
Check the Alignment Guides options you would like 
to use. To turn a guide tool off, uncheck it.

Select Show guides for active objects to display a 
guideline when you move an object into alignment 
with another object. Guides will appear on the page 
to assist you in aligning objects to any side or center 
of a nearby object.

Select Show vertical page center guide to display 
a guide when you move an object toward the page’s 
vertical center.

Select Show horizontal page center guide to display a guide when you move an object toward 
the page’s horizontal center.

If you would like objects to snap to guidelines as you move the object on the SMART Notebook 
page, check the Snap objects to guides option.

To change the guide color, press the Guide color box and choose a new color from the palette.

If you have turned on any of the alignment guides, they will appear when appropriate when you are 
working on the SMART Notebook page. As you move an object in range of another object, or the 
horizontal or vertical center of the page, the guides will appear. If you selected Snap object to 
guides, your object will automatically snap into place on the guideline.

You can customize the active alignment feature by 
selecting only those alignment guides you would like to 
see when working in SMART Notebook software. 
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Tables
To add a table, complete the following steps:

  1  Press the Table button or select Insert > Table. An eight by eight grid appears.

  2  Select the number of columns and rows that you would like to include in the table by dragging 
over the cells in the grid

  3  The table appears on the SMART Notebook page

Adding text and objects to tables
Once you have created your table, you can add text and objects, including freehand objects, 
geometric shapes, straight lines and graphic files to the table cells simply by dragging and dropping. 
To add text to a table cell, double-click on a cell. A text box will appear. To add an object to a table, 
select the object and drag it to the destination cell. To remove an object from a table, select it and 
drag it out of the table. 

Selecting tables, columns, rows or cells on a 
SMART Notebook page
You can select a table, a column, a row, an individual cell or a selection of cells. After you have 
selected a table or a part of a table, you can modify the properties of the selected area. 

Selecting a table is easily accomplished using the marquee select method. Use the select tool, and 
drag a rectangle to encompass the entire table.

To select cells, rows or columns, press inside the table area and drag over the specific cells you 
would like to select.

TIP: Each cell can contain only one object. If you would like to add multiple objects to a cell, for 
example, an image and a text descriptor of the image, group the objects before adding them to 
the table.
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Moving and resizing tables
To move a table on the SMART Notebook 
page or to another page, select it. A 
square handle appears in the table’s 
upper-left corner. Use this handle to drag 
the table to the desired location.

To resize a table, select the table and 
press the resize handle in the lower-right 
corner of the table. Drag the handle to 
increase or reduce the size of the table.

Press and drag
this handle to

move the table.

Press and drag 
this handle to 
resize the 
table.
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Resizing columns and rows 
You can resize rows and columns by pressing 
the table lines and dragging them to adjust 
them to the preferred size. For example, to 
expand the width of the first column, press the 
vertical line to the right of the column. A 
double-headed arrow appears. Drag the 
vertical line to the right to create a wider 
column. You can use this method to alter the 
size of any row or column, but you are limited 
by the height and width of the table. If you 
would like to increase the height or width of 
the table, drag the outer edge of the table to 
the desired height or width.

Inserting or removing columns, rows or cells
After creating your table, you can customize it by inserting or removing columns, rows and cells. To 
add a new column or row, select a column or row, right-click and select Insert Column or Insert 
Row. New columns will appear to the right of the selected column. New rows will appear below the 
selected row. 

To remove a column or row, select a column or row, right-click and select Delete Column or Delete 
Row. The currently selected row(s) or column(s) will be deleted.

You can also delete an individual cell or group of cells from a table. For example, when creating a 
crossword puzzle, you wouldn’t want a complete grid to appear. To delete unnecessary cells, select 
the cell(s) you would like to delete, right-click and select Remove Cells.

Splitting or merging table cells on a SMART Notebook page
To further customize the appearance of your table, you can split and merge cells. To split a cell 
means to turn one cell into two or more cells within the same area. SMART Notebook software 
provides several options for splitting cells, including split into 2x2, split into 3 rows and several other 
options.

To merge a cell means to turn two or more cells into one cell that then occupies the same area as 
the individual cells. To merge cells, select the cells, right-click and select Merge. 

To adjust column width, press on the line and drag it.
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Cell shades
Cell shades are similar to a Screen Shade, but they cover and 
reveal the contents of individual cells within a table. Cell shades 
enable you to reveal the table content at a pace appropriate to the 
lesson. You can add a cell shade to an individual cell, a group of 
cells such as a row or column, or an entire table.

To add a shade to a cell, multiple cells or an entire table, select the 
cell(s). Right-click and select Add cell shade.To remove a shade 
from a cell, multiple cells or an entire table, select the cell(s), right-
click and select Remove cell shade.

To reveal the contents of a cell covered by a cell shade, press once 
on the cell shade.

The answers are hidden using 
cell shades. To reveal the 
contents of the cell, press 
once on the cell shade.
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Lesson pages
Ready-made pages make it easier for you to add structure and style to your lessons, and using 
consistent page templates lets the viewer know where to look for information. You can find 
templates for title pages and lesson pages in the Pages folder of the Lesson Activity Toolkit.

To add one of these templates to your lesson, drag and drop it onto any page of the SMART 
Notebook file, then fill out the page to suit your lesson activity. Double click the default text to edit 
it, as you would any SMART Notebook text.

Venn Diagram example of a 
SMART Notebook lesson 
page template
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Graphics
Icons and images from the Graphics folder will help you create sophisticated and engaging 
language arts lessons. Title bars and pull tabs can be dragged directly onto the SMART Notebook 
page. You can assign page links and weblinks to buttons and icons to make the lesson more 
interactive and engaging, and improve the flow. The Lesson Activity Toolkit provides all items in five 
colors, enabling you to select a background in your preferred color, and coordinate the graphics, 
icons and buttons. 

You can add links to buttons and any other graphic from the Lesson Activity Toolkit to improve the 
flow of your lesson. To add a link to an object, complete the following steps:

  1  Select the object drop-down menu
  2  Select Link
  3  Edit the link location details in the Insert Link dialog box
  4  Select whether to launch the link by clicking the corner icon or the object
  5  Press OK

Icons from the 
Lesson Activity 
Toolkit

Buttons from the 
Lesson Activity 
Toolkit

Standard text 
messages from the 
Lesson Activity 
Toolkit
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Review: Adding style to lesson activities
  1  How do you turn active alignment on?

  2  How do you move a table?

  3  How do you add a cell or table shade?

  4  What’s the difference between a theme and a background?

  5  List four items you can modify in the Properties side tab.
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Adding style to lesson activities Q and A
Review: Adding style to lesson activities
  1  How do you turn active alignment on?

Select Format > Alignment. The Alignment Guides dialog box appears. Check the 
Alignment Guides options you would like to use and click OK.

  2  How do you move a table?

To move a table on the SMART Notebook page or to another page, select it. A square 
handle appears in the table’s upper-left corner. Use this handle to drag the table to the 
desired location.

  3  How do you add a cell or table shade?

 To add cell shades to an entire table, select the table, press the table’s menu arrow and 
select Add table shade. To add a shade to a cell or multiple cells, select the cell(s), right-
click and select Add cell shade.

  4  What’s the difference between a theme and a background?

A theme controls the formatting of typed text on the page, a background does not. 

  5  List four items you can modify in the Properties side tab.
•  The color, transparency and fill effects of objects
•  The color, thickness and style of lines
•  The font type, size and style of text
•  The animation settings for objects
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Building interactive 
lesson activities
How can I  take advantage of  the 
interact ive features in 
SMART Notebook software in my 
lesson act iv i t ies?

SMART Notebook software includes many tools and features that enable you to make lesson 
activities that are engaging and interactive. Bringing students up to the interactive whiteboard 
provides them with a hands-on experience that they will remember. 
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Building interactive lesson activities
Dual Page Display and Pin Page
In some lesson activities, you may want to display two pages side by side. For example, you may 
want to display new vocabulary words on one page and an activity on another page, or you may 
want to display steps to solving a particular type of math problem on one page and a math question 
for your students to complete on another page. You can display both of these pages at once using 
Dual Page Display. You can draw, make notes, import files and add links on either page just as you 
would on a single page, and even move objects between the two pages.

To use Dual Page Display, press the Dual Page Display button  on the SMART Notebook  
toolbar or select View > Zoom > Dual Page Display. The work area will be split into two panes 
showing two consecutive SMART Notebook pages.

To close Dual Page Display, press the Single Page Display button  on the SMART Notebook 
software toolbar or select View > Zoom > Single Page Display.

Dual Page Display allows two SMART Notebook pages to be displayed at the same time.
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Pin Page
When working in Dual Page Display, the Pin Page feature enables you to lock one page in place 
while still using the other pane to navigate through your SMART Notebook pages. For example, 
when introducing new vocabulary, you may want to keep a vocabulary list displayed on one page, 
and display various activities in the other pane. This approach enables students to refer to the new 
terminology or drag the vocabulary words onto the activity pages as needed. 

To pin a page, navigate to the page you want to pin – in this scenario, the vocabulary list – and 
select View > Zoom > Pin Page. Thumbtack icons appear in the top corners of the pinned page. 
When you press the Next Page button, only one of the two displayed pages – the one without the 
thumbtack icons – will change. You can unpin the page by following the same steps.

The pin icons
indicate that

this page will
remain

stationary
when you

advance to
the next page.
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Attaching sound
The sound capabilities for SMART Notebook software are an ideal tool for teaching language skills 
and will also appeal to auditory learners. Attaching an audio clip to an image enables students to 
see a word and hear it pronounced at the same time. You can also attach longer sound files, 
including sound effects, songs and conversations that students can listen to, repeat and discuss.

To attach a sound file to an object, complete the following steps: 

  1  Select the object that you would like to attach a sound file to
  2  Select Sound from the object’s drop-down menu. The Insert Sound dialog box appears.
  3  Type the name of the sound file to attach to the object, or press Browse to locate and select 

the sound file
  4  Press the Play button if you would like to preview the sound to ensure it is the right file
  5  Select whether you’d like to launch the sound by clicking a corner icon or the object
  6  Press OK. The sound file is now associated with the object and the sound file is saved as a 

part of the SMART Notebook file.

TEACHER TIP: An interesting way to use sound in a lesson is to place several words, each with a 
sound file containing the correct pronunciation of the word attached, on the SMART Notebook 
page. Students can rearrange the words to build sentences. After creating the sentence, they can 
press the words to hear the sentence and make sure it makes sense and repeat what they hear. 

Song is also a fun way to use sound in lesson activities. Attach a verse of a song to a text object 
containing the lyrics. Students can listen to the song and follow along by reading or singing the 
lyrics displayed on the SMART Notebook page.

Select whether you would like the sound file to launch when a person presses 
the object, in this case – the image of the bear – or by pressing a corner icon.

Students can press the 
sound icon to hear the 

word “bear.”
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Object Animation
You can add excitement to your lesson activity and emphasis to key points by using Object 
Animation. You can animate an object to fly in from the side of the page, spin, fade in, shrink and 
more, choosing when the animation takes place, at what speed and for how long. You can add 
animation to a text object or any object created with the Shapes tool or any of the pen tools.

To animate an object, complete the following steps:

  1  Select the object you would like to animate
  2  Open the Properties tab
  3  Select the Object Animation tab 
  4  Using the drop-down lists provided, select the 

animation Type, Direction and Speed
  5  Select the animation timing from the Occurs drop-

down list. You can set the animation to take place 
when you enter the page or when you click the 
object.

  6  Select how many times the animation repeats from 
the 
drop-down list

Drop-down menus enable you to easily select 
and modify object animation properties.
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Interactive resources from the 
Lesson Activity Toolkit
The Lesson Activity Toolkit contains several interactive resources that will keep your students 
engaged and make learning fun.

Games and activities
The table below lists only some of the resources available in the Lesson Activity Toolkit, so be sure 
to browse through the folders to find additional activities and games that work for you, and creative 
ways to use them. The Examples folders can help you generate some ideas.

To add an item from the Lesson Activity Toolkit to your lesson, select a thumbnail image and drag 
and drop it onto the work area. 

Editing an activity or game

Most Flash activity and game templates have an Edit button that enables you to customize the 
activity or game, and a Help button that displays detailed instructions for building and using it. Press 
Edit to get started. Fill in the blanks and make any selections required to set up the activity or game. 

Activities Games

Category sort Board games

Keyword or image match Crossword

Multiple choice Deck of cards

Sentence arrange Dice

Tiles Dominos

Timeline reveal Soduku
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When editing the activities, games and tools, you can add text by typing in the text fields, or by 
dragging and dropping text from the SMART Notebook page, word processing software or a 
webpage or other software program, into the text fields to speed-up activity creation. For example, 
if creating a multiple choice activity, you can drag both the questions and answers from your existing 
quiz found in a word processing document.

If you would like to ensure that others cannot edit your activity or game, check the Password box, 
and set a password. This action can prevent participants from accidentally accessing the edit area 
of the activity during class.

Lesson Pages

For more creative control over the lesson activity, there is a version of most activities that is created 
entirely from SMART Notebook objects. You can find Lesson Page activites in the Pages folder of 
the Lesson Activity Toolkit. 

Press OK to save your edits.

Check this box and type in a 
password to protect the activity 
or game from being edited.

You can 
customize the 
parameters of 
many 
activities.

Check this box to show a Solve
button during the activity.
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Tools
The Tools folder includes several 
useful tools, including random number, 
letter, card and domino generators, 
image and keyword dice, a voting tool, 
information buttons and word 
generators, scrolling text bars and 
many others, that you can use to add 
interactivity to your lesson activities. The tools in the Examples folder can help you generate some 
ideas. 

When editing the tools, you can add text to a field by typing in a text field, or by dragging and 
dropping text from the SMART Notebook page into a text field.
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Pull tabs
Pull tabs are a useful tool found in the Lesson Activity Toolkit that are designed for hiding text or 
objects on a SMART Notebook page until you are ready to reveal them. Pull tabs can be used to 
detail activity instructions and provide hints. They enable you to include a lot of information on a 
page, without cluttering it. 

You can also create your own pull tab object using the Shapes tool. Consider saving the pull tab in 
your My Content folder if you will use it often.

Creating pull tabs

  1  Select a pull tab from the Graphics folder or create your own pull tab object
  2  Drag the pull tab onto the work area
  3  Add the pull tab text to the workspace using the text button
  4  Select both the text object and the pull tab (press Ctrl and click on each one) 
  5  Select Grouping > Group. The two objects will behave as one object.
  6  Move the pull tab until the text is hidden on the edge of the page
  7  During your lesson, use the pull tab to reveal the hidden text or image by pulling it toward the 

center of the workspace 

Help
The Help folder in the Lesson Activity Toolkit contains links to additional information and 
supporting materials for the Toolkit.

Pull the pull tab to reveal the hidden text.Place the pull tab at the edge of the 
workspace or object to hide the 
attached text.
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Review: Building interactive lesson activities
  1  How do you turn on Dual Page Display?

  2  How do you attach a sound file to an object?

  3  What are three object animation styles?

  4  What are two ways to add text to a text field in an Adobe Flash activity, game or tool from 
the Lesson Activity Toolkit?

  5  How do you create a pull tab?
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Review: Building interactive lesson activities
  1  How do you turn on Dual Page Display?

Press the Dual Page Display button on the toolbar or select View > Zoom > Dual Page 
Display.

  2  How do you attach a sound file to an object?

Select the object that you would like to attach a sound file to and select Sound from its 
drop-down menu. The Insert Sound dialog box appears. Press Browse to locate and 
select the sound file. Select whether you’d like to launch the sound by clicking a corner 
icon or the object, and press OK. 

  3  What are three object animation types?

Fade in, fade out, flip around axis, fly in, fly out, shrink and grow, and spin

  4  What are two ways to add text to a text field in an Adobe Flash activity, game or tool from 
the Lesson Activity Toolkit?

You can add text by typing into the text fields, or by dragging and dropping text from the 
SMART Notebook page, word processing software or a webpage or other software 
program, into the text fields to speed up activity creation. 

  5  How do you create a pull tab?

Select a pull tab from the Graphics folder and drag it onto the work area. Position it next 
to the object you would like to group it with. Select both the object and the pull tab (press 
Ctrl and click on each one), and select Grouping > Group. Move the pull tab until the 
text is hidden on the edge of the page.
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Integrating 
rich media into 
lesson activities
How can r ich media add value to 
my lesson act iv i t ies?

Rich media files and tools appeal to a variety of learning styles, can add interactivity to the lesson 
and can save you time.
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Integrating rich media into lesson activities
There are many ways that you can take advantage of various types of rich media when creating 
lesson activities with SMART Notebook collaborative learning software and a SMART Board 
interactive whiteboard. 

In addition to the Internet, there are several other ways that media can be incorporated into a lesson 
activity. You can record and replay actions with the Page Recording feature in SMART Notebook 
software or the SMART Recorder. You can play, pause and write over video using the SMART 
Video Player. You can also easily import images and documents into SMART Notebook software.

Using your favorite websites
The Internet is a great resource for all kinds of information that can be useful in your lessons. 
Incorporating this information quickly and easily can save you lots of time and effort. In many cases, 
it is much more efficient to simply use an Internet resource, such as an existing lesson, rather than 
having to recreate it yourself.

Finding teacher-recommended websites 
The SMART Exchange online community has many resources that you can use for lesson material, 
including teacher-recommended websites for a variety of topics. Using these recommendations is 
a great way to access easy, high-quality references and information for your lessons.

To find a recommended 
website, open your internet 
browser, and browse to 
exchange.smarttech.com

Type keywords for your topic in 
the search box, and then click 
the search button.
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Click Web Pages in the Narrow results by type pane. If Web pages is not listed then your search 
did not find any recommended web pages to match your keywords. Try revising your keywords. 

Click Web pages to display a 
list of teacher recommended 
web pages for your search 
topic.

Click the Visit external web 
page button to view the web 
page.
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Using the Transparent Background view
You can use the Transparent Background view to display the desktop or any open application 
behind the SMART Notebook window and continue to interact with the open, transparent file. You 
can draw in digital ink on a transparent page and save your notes. You can also display 
measurement tools, take screen captures and more. If an area of the transparent SMART Notebook 
window doesn't include any objects, you can select and interact with the desktop and applications 
behind the SMART Notebook window.

To turn on the transparent 
background, press the 
Transparent Background  
button on the SMART 
Notebook toolbar or select 
View > Transparent 
Background. The SMART 
Notebook page becomes 
transparent, and the 
transparent background toolbar 
appears. 

If there are objects on the 
transparent SMART Notebook 
page they are still visible, and 
any added objects or ink 
remain on the SMART 
Notebook page when you 
return to standard view.

To return to standard view, 
press the Transparent 
Background button on the 
transparent background 
toolbar.
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Page Recorder
Using the Page Recorder, you can record any actions completed on the current SMART Notebook 
page, including writing with digital ink, adding and modifying objects, and creating shapes. This 
recording is saved as a part of the SMART Notebook file and can be replayed at any time from that 
SMART Notebook page. The Page Recorder enables you to record an example of an activity or 
problem to replay when using the lesson activity in class. If students are working independently at 
the interactive whiteboard, they can view and re-view instructions and examples without seeking 
the help of the teacher. 

To record actions on a SMART Notebook page, complete the following steps:

  1  Open the Properties tab
  2  Press the Page Recording button
  3  Press the Start Recording button
  4  Complete any actions on the SMART Notebook page that you would like to record
  5  Press Stop Recording
A Page Recording toolbar appears at the bottom of the 
SMART Notebook page, which enables you to play and 
pause the recording from this SMART Notebook page at 
any time. 

You can also play a recording by pressing the Play button 
found in the Page Recording section of the Properties tab. 

Back Pause Play Record
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SMART Recorder 
With SMART Recorder, you can make a video recording of your lesson, no matter which 
applications you are using on the interactive whiteboard. If you have a microphone attached, you 
can also record your voice. For example, this feature enables you to record sample math problems, 
incorporating the use of the on-screen calculator or spreadsheet, then replay the file as a review for 
your students or for those who missed the lesson. Recordings can be played using SMART Video 
Player or Windows Media® player (available free from www.windowsmedia.com/download). You 
can also use the SMART Recorder to record student work on the interactive whiteboard as a form 
of assessment.

SMART Recorder has a simple three-button interface 
that enables you to control the recording process. 

To record actions on the SMART Board interactive 
whiteboard, complete the following steps:

  1  Press the Record button. By default, SMART 
Recorder records the entire workspace, although 
you can modify this setting.

  2  Complete the actions you would like to record
  3  Use the Pause and Record buttons throughout the recording as required
  4  Press the Stop button to end the recording
  5  You will be prompted to save the file. Select a location, name the file and press Save.
  6  The Recording Complete dialog box appears, providing details of the recording, including file 

size and recording time
  7  If you would like to immediately view your recording, check Play Recording
  8  Press OK

Record Pause Stop
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Hiding the SMART Recorder
If you do not want the SMART Recorder to be 
visible in the recording, or you don’t want it to 
distract your students, you can hide it in the 
notification area.

To do this, press the Menu button and select 
Hide to System Tray. 

Click on the SMART Recorder icon to access 
a menu providing you the same access to 
Record, Pause, Stop and other features of 
Recorder. Select Show to restore the SMART 
Recorder to full size.

The SMART Recorder icon in 
the notification area.
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Setting the recording area
SMART Recorder has three options for the region of the 
workspace that will be recorded. Selecting a smaller 
recording area will reduce the file size and can eliminate 
distractions from the recording, such as the task bar or 
any applications that are open but not necessary for the 
lesson.

To specify the portion of your desktop that you would like 
to record, press the arrow beside the Record button, and 
select from the following three options: 

•  Record Desktop (Default) – Records the entire desktop
•  Record Area – Prompts you to select the area of the screen you would like to record
•  Record Window – Prompts you to choose a window that you would like to record

Record Area has been selected. Therefore, only the area within the red border will be recorded. This will 
eliminate distractions such as the calculator, Notepad and desktop icons.
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SMART Recorder Menu
The SMART Recorder Menu button provides access to several options and settings that you can 
modify to make SMART Recorder work best for you. To access these settings, select Options from 
the Recorder Menu to launch the Options dialog box.

The Recording Quality 
tab enables you to adjust 
the quality levels of the 
sound and video recorded, 
which also has an impact 
on file size. For example, 
you can change the 
number of frames per 
second you record. Movies 
recorded at a low frame 
rate have a smaller file size 
than those with a higher 
frame rate, but the visual 
quality of the movie is 
reduced. 

The Video Format tab 
allows you to choose a file 
format to save your movie. 
The Windows Media Video 
Files option creates a file 
that can be viewed with 
Windows Media player. 
The SMART Recorder 
Video option creates a more compressed file, resulting in a smaller file size. This file can be viewed 
only if SMART Board software is installed on the computer playing the video.

Select the Target Files tab to change where your Recorder files are saved on your computer. 

The Watermark tab enables you to add an image or text watermark to your recording, which would 
be visible anytime the file is played. You could use this feature to include course or unit titles, the 
date of the lesson or your school’s logo. You can adjust the placement of the watermark on the 
recording, and the font size, style and transparency of the watermark. You can also set a standard 
watermark to use each time you create a recording or select Turn off watermark when SMART 
Recorder closes to revert to using no watermark.
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SMART Video Player
With SMART Video Player, you can play video files located on your computer or an external device, 
such as a camera, VCR, CD-ROM, DVD player or document reader.

Although other video players work on a SMART Board interactive whiteboard, when you are using 
SMART Video Player, you can write over the video, whether it is moving or still. The transparency 
layer does not appear over SMART Video Player when you pick up a pen tool from the pen tray. 
With other video players, the transparency layer appears, and the video seems to be paused while 
you are writing. However, it actually continues to play in the background and you miss portions of 
the video. 

If you are writing notes you would like to save for later use, you can write over a frame of video and 
capture your notes to SMART Notebook software. 

To launch SMART Video Player, click the SMART Board icon in the notification area and select 
Video Player.
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SMART Video Player has an easy-to-use button interface that enables you to play and pause video, 
and set your preferences for using digital ink with the SMART Video Player.

Button Use this tool to

Show how much time is remaining in a movie

Play or pause the movie

Stop the movie and rewind it to the beginning. When using the 
pen tool, this button changes to a Clear Screen button, enabling 
you to remove any notes written over the video.

Capture the current frame to SMART Notebook software

Return the mouse to cursor mode

Use the cursor as a pen tool

Change the color of the digital ink

Change the line thickness of the digital ink

Clear any notes written over the video

View the video in full-screen mode

Set the video to repeat continuously

Mute the sound

Adjust the volume
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To view a video file, select File > Open and browse to a video file on your computer. When you 
have located the file, click Open. 

When you connect a video hardware device (such as a VCR, video camera or document camera) 
to your computer system, SMART Video Player detects the device and adds it to the Hardware 
menu. To view video from one of these devices, select it from the Hardware menu.

Play list
SMART Video Player has a play list feature that enables you to prepare and save a list of videos to 
use in your lesson. To view the play list, select View > Show Playlist. To add a file to the play list, 
press the Play List button and select Add. You can also reorder and remove files from the play list. 
To save the play list for future use, press the Play List button and select Save.
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Video Player Settings
As there are many different potential uses for the SMART Video Player, there are several settings 
that you can change to customize the way that the Video Player works and responds to your 
actions, including the video playback speed, what happens when you pick up a pen tool and how 
long any notes you make are displayed on the screen. 

To access the Video Player Settings dialog box, select Settings > Video Player Settings.

Pause while writing
The default setting for Video Player is to pause 
whenever you pick up a pen tool. With this 
setting, you can stop the video, make notes and 
lead a discussion with your students. When you 
are ready, you can put the pen down to continue 
watching the video. Alternatively, you can 
deselect the Pause when tool(s) lifted check 
box, changing the settings so that the video 
continues to play when you are using the pen 
tool. This action enables you to highlight 
important points on the screen without 
interrupting the flow of the lesson. 

Fading out annotations
As the video plays, you might want your notes to 
disappear without having to press the Clear 
Screen button. To enable or disable the Fade out 
notes option, complete the following steps:

  1  Select or deselect the Fade out notes 
check box

  2  Designate the amount of time (in seconds) 
that should pass before the digital ink begins to fade and how long it should take to clear the 
screen

  3  Press OK
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Remembering the hardware source
If you frequently use SMART Video Player to display video from an external source, such as a DVD 
player or electronic microscope, you can save on preparation time by checking the Remember last 
hardware source option. SMART Video Player will automatically look for a video file on the last 
hardware source used.

Removing the toolbar in full-screen mode
To ensure that the video is visible for the entire class, you 
may want to display the video in full-screen mode, using the 
entire interactive whiteboard. When you select the full-screen 
view, a different toolbar appears with buttons for playing and 
pausing the video, and for capturing and clearing your 
writing. This toolbar also includes a button for returning to 
normal view. 

Use the Remove toolbar in full-screen mode option to set how long this toolbar remains on screen. 
To access the Video Player toolbar after it has disappeared, touch the interactive screen.

Video Playback Speed
You can adjust the speed of video 
playback by selecting Settings > 
Playback Speed. Tailor the video 
playback to your class needs by selecting 
at a slower or faster speed. 
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Import images
In addition to using the many images and objects included in the Gallery, you can easily import your 
own pictures into a SMART Notebook file. To insert a picture from a file on your hard drive or 
network, complete the following steps:

  1  Select Insert > Picture File. The Insert Picture File 
dialog box opens. 

  2  Locate your picture file 
  3  Select Open to import the image into the current 

SMART Notebook page

You can also import printed material, such as an 
overhead transparency sheet, if there is a scanner 
connected to your computer. 

  1  Select Insert > Picture From Scanner. The Insert 
Scanned Picture dialog box opens.

  2  Select a scanner from the list
  3  Press the Scan button
  4  Scan your picture and adjust it as needed, following the instructions provided by the scanner’s 

software
  5  When the scan is complete, close the dialog box and return to SMART Notebook software
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Importing a file with SMART Notebook Print 
Capture
SMART Notebook Print Capture is a printer driver installed with SMART Notebook software that 
imports a file or specified pages of a file into the SMART Notebook file. Each page of the imported 
file appears as an object on its own SMART Notebook page, with its original formatting and page 
breaks preserved. This feature is different than Capture to SMART Notebook software, because it 
enables you to import full pages, page ranges and files, not just the visible work area.

You can import Microsoft® Word software documents or any other type of document that you would 
normally be able to print. This feature is particularly useful if you have existing electronic resources, 
but you would like to take advantage of the interactivity that SMART Notebook software enables. 

To import a file using print capture, complete the following steps:

  1  In the source application, select File > Print. The Print dialog box opens.
  2  Select SMART Notebook Print Capture from the list of printers
  3  In the Print dialog box, select a page range
  4  Press OK

NOTE: If SMART Notebook software is already open, the pages from the source file are 
added to the SMART Notebook file after the current SMART Notebook page. If SMART 
Notebook software is not already open, it will launch. 

Changing the properties of the SMART Notebook Print Capture 
driver
When you import a file with SMART Notebook Print Capture driver, each page appears as an image 
on its own Notebook page. Just as with any printer driver, you can change the page orientation and 
additional print properties.

To change the page orientation, do the following:

  1  In the source application, select File > Print. The Print dialog box opens.
  2  Select SMART Notebook Print Capture from the list of printers
  3  Press the Properties button. The SMART Notebook Print Capture Properties dialog box 

opens.
  4  Select Landscape orientation or Portrait orientation
  5  Press OK
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Lesson development 
in SMART Notebook 
software
How can SMART Notebook 
software help me to arrange the 
curr iculum into interest ing and 
ef fect ive lessons?

Try integrating the tools and features covered in this workbook to build a lesson activity that you can 
use in your classroom.
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Lesson development in SMART Notebook software
Hands-on practice
Create a lesson activity in SMART Notebook software that you can use in your own classroom. 
The lesson activity should contain the following items:

•  Teachers’ notes and lesson notes
•  At least four pages
•  Objects, backgrounds and multimedia objects from the Gallery

When developing the lesson activity, try to include at least two of the skills you learned today:
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Delivering lessons 
and leveraging 
interactive tools
How can I  enhance my del ivery of  
lessons using SMART Notebook 
software?

This section aims to enhance your delivery of interactive whiteboard lessons through organizational 
best practices, customization of the SMART Notebook interface, delivery tips and hands-on 
practice leveraging interactive tools.
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Organization and planning for a sophisticated 
delivery
The best way to prepare yourself for delivering your lessons on a SMART Board™ interactive 
whiteboard is to create well-organized, well-designed SMART Notebook software lessons. 

An organized, well-designed lesson will enable the following:

•  Smooth and effective navigation from page to page
•  Clear and concise presentation of lesson content
•  Increased flexibility to address student needs
•  Clear expectations of what students or substitute teachers are to do during a lesson 

activity
•  Lesson activities that perform as intended
•  Minimal transition time between documents or activities, resulting in more effective 

classroom management

Organization and planning notes

Please use the space provided below to note some features of SMART Notebook software that 
will help you organize and design your lesson for an effective delivery.
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Design your lesson to be delivered interactively
A SMART Board interactive whiteboard is different from a digital projector and screen in that it is 
designed to be an interactive medium. A presentation graphics program such as Microsoft 
PowerPoint® software can certainly be used on an interactive whiteboard, but showing pre-
prepared slides in a linear format is not the only or best option for lesson delivery on an interactive 
whiteboard. The interactivity of whiteboards equipped with collaborative learning software allow and 
encourage teachers to be flexible, nonlinear and spontaneous in their lesson delivery.

If lecture-style delivery is your preferred teaching method, there are still many advantages to using 
an interactive whiteboard. However, to make maximum use of this tool, consider experimenting with 
incorporating some interactivity into your lessons. Easy places to start are question-and-answer 
type interactivity, diagram labeling and the use of interactive learning objects created in Flash® 
software.

Organization and planning notes, continued
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Customizing SMART Notebook software for 
effective lesson delivery
Teachers with a sophisticated delivery style don’t distract their students from the lesson by 
searching for the tools they need. Customize the SMART Notebook interface to put all the tools you 
need for your unique delivery style at your fingertips. This section outlines several of the 
customization options included in SMART Notebook collaborative learning software.

Customizing the Floating Tools toolbar
The Floating Tools toolbar provides instant access to interactive 
tools that will help you deliver amazing lessons whether you are 
using SMART Notebook software or another application on the 
SMART Board interactive whiteboard. 

By default, the Floating Tools toolbar is anchored to the left-hand 
side of the interactive whiteboard. If you are right-handed and find 
yourself needing to access it frequently while writing and 
navigating, you may wish to drag this toolbar to the right-hand side 
of the screen before beginning your lesson.

Customize the properties of the tools that have side menus to 
minimize delivery time spent setting them up to be useful for your 
lessons. Press the Customize button on the side menu. The 
Properties dialog box will appear where you can change the 
settings for the tool.

Floating Tools 
toolbar 
(default settings)

Hide/Reveal 
toolbar

Move toolbar
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You can save the new settings so they become the default for that tool by clicking the Save Tool 
Properties button at the bottom of the dialog box after you’ve set the parameters above.

Customize your Floating Tools toolbar so that it contains all the tools you find yourself using 
frequently in your lesson delivery. 

Press the Customize button in the Floating Tools toolbar to choose from a variety of 
toolbar icons. You can choose as many icons as you like to fully customize this toolbar with 
the tools you need most often.

To add a button to the Floating Tools, drag and drop the icon onto the toolbar. To remove a button, 
ensure the Customize button has been pressed, and drag the button off the Floating Tools toolbar.

To return the toolbar to its original configuration, press the Restore Defaults button.

When you are finished customizing the toolbar, press the Done button.

Properties dialog boxSide menu Customize button
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Customizing the interface in SMART Notebook 
software
Several options are available for customizing the interface of SMART Notebook software so that it 
reflects your delivery style and the needs of your classroom. 

Customizing the toolbar
Arrange and customize the toolbar in SMART Notebook software so that it best suits your delivery 
needs. Remove tools that don’t appeal to you or that you never use – this keeps your favorite tools 
more accessible. Place the tools that you use most often near the side of the interactive whiteboard 
where you tend to stand when delivering your lessons. It is a good idea to keep buttons with similar 
functions next to each other. For example, in the default toolbar, all of the page navigation tools 
such as Next Page, Previous Page and Add New Page are found in the same area of the toolbar. 

Keep in mind that rearranging your toolbar regularly may confuse students and detract from the 
effective delivery of your lessons. It is best to decide on an arrangement that suits your delivery 
needs and stick      with it.

To customize the toolbar, right-click on any button in the toolbar to launch the Customize Toolbar 
window. Use this window to add or remove buttons from the toolbar. Drag a button from the toolbar 
to the Customize Toolbar window to remove it from the toolbar. Drag a button from the Customize 
Toolbar window into the toolbar to add it to the toolbar. When the Customize Toolbar is open, you 
can also rearrange the buttons within the toolbar by dragging them to another location.

When you are finished customizing the toolbar, press Done.
82



SMART Notebook Software Training for SMART Board Users Level 2 Learner Workbook
Placement of the toolbar
By default, the toolbar in 
SMART Notebook software 
is located at the top of the 
workspace. This is the most 
accessible location for 
teachers and older students 
to use the tools. If young 
students or students with 
mobility concerns are using 
the SMART Board interactive 
whiteboard, you may need to 
move the toolbar to the 
bottom of the workspace for 
easier reach. To move the 
toolbar from the top to the 
bottom of the workspace, or 
vice-versa, press the double-
sided arrow icon.

Sometimes, you may wish to 
limit access to a toolbar 
during a lesson so that it is not accidentally pressed. In this scenario you might move the toolbar to 
the least accessible position, at the top or bottom of the workspace.

Placement of the side tabs
By default, the side tabs appear on the right-hand side of the workspace. These can be moved to 
the opposite side of the workspace by pressing the double-sided arrow icon. To facilitate your 
lesson delivery, it is best to place the side tabs on the side of the board where you tend to stand 
when delivering your lessons. Left-handed presenters may find the side tabs more accessible on 
the left side of the workspace, whereas right-handed presenters may find the side tabs more 
accessible on the right side of the workspace.

Check the Auto-hide check box to hide the side tabs from view and give yourself more workspace 
area. However, leaving the Page Sorter tab visible while delivering a lesson puts the current page 
into the context of the whole lesson. This approach helps some teachers organize their thoughts for 
a more effective delivery.

Double-sided
arrow icon
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Presentation tips for delivery on an 
interactive whiteboard

Body positioning
Face your students as much as possible while manipulating the SMART Board interactive 
whiteboard.

Keep your body position

When you need to reach something on the 
other side of the interactive whiteboard,

When writing on the interactive whiteboard,
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Touch tips

TIP: Remember to orient your SMART Board interactive whiteboard before every presentation to 
ensure an accurate reading of your touch.

The most effective hand position for moving 
or touching an object is

This is because
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Writing tips
Writing on an interactive whiteboard involves a slightly different technique than writing on a 
conventional whiteboard or chalkboard. Like any skill, it takes practice. Note some tips to improve 
your SMART Board interactive whiteboard annotations.

Manipulate the interactive whiteboard from the screen
One of the advantages of an interactive whiteboard is that teachers can instruct from the front of 
the room – near the projected image – and navigate their digital lesson while facing their students. 
Teachers who navigate their interactive whiteboard from the back of the room so that they can use 
a mouse are not effectively using the technology.

Go ahead, mark up those documents
The interactive whiteboard is a great tool for highlighting and jotting notes on just about any type of 
application or document. So go ahead, use the tools as intended and mark up that electronic 
document. You can save these markings or delete them, it’s up to you.
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Leveraging interactive tools
Use the space below to note key ideas for leveraging the interactive tools included in SMART 
Notebook software.

Interactive tools Why/where would I use this tool in my lesson delivery?

Circle to erase

Creative Pen

Dual Page Display

Export

Full Screen view

Transparent Background 
view

Handwriting recognition

Highlighter

Insert Blank Page

Lesson Activity Toolkit tools

Magic Pen disappearing ink
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Magic Pen zoom

Magic Pen Spotlight

My Content

Page Recording

Recognize Shape

Interactive tools Why/where would I use this tool in my lesson delivery?
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Responsive lesson delivery
As a teacher, you know that it can be desirable to deviate from planned lessons in order to stay 
responsive to the needs of your students.

SMART Notebook collaborative learning software has a number of tools to help you stay responsive 
to student needs and manage your classroom effectively:

•  Enrichment tasks for students who finish early
•  Transition activities for in-between time
•  Impromptu explanations or demonstrations
•  Extensions onto planned lessons
•  Unplanned review of previous material

This section outlines several ideas to give you something to draw upon when you need to respond 
quickly to your classroom environment.

Leverage the power of the Internet
The Internet is a powerful source of information that youth readily turn to for answers to their 
questions. Planned or impromptu forays onto the Internet are easy to make during an interactive 
whiteboard lesson. 

Experiment with Transparent Background view as a way to use SMART Notebook objects  with a 
web page, or preserve the notes you make on a web page.

Example of Transparent Background 
view being used to display guiding 
questions (a SMART Notebook text 
object) while students search a web 
page for answers.

Their notes are automatically stored on 
the SMART Notebook page.
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Use SMART Notebook software as a course management tool
Use SMART Notebook software as a tool to collect and organize relevant documents, websites, 
videos, images, notes and activities. This sets you up with an easily accessible collection of 
information to draw on when you need to spontaneously provide further explanation for a concept 
or extend your lesson in meaningful ways.

Store and organize lesson resources using:

•  The Attachments tab 
•  The My Content folder
•  A collection of links on a SMART Notebook page

TIP: It is a good idea to back up your My Contents folder. Click on the main My Contents folder 
and select Export as Collection File... from the drop-down menu.
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Use setup-free lesson tools
Tools such as the Random letter generator, Random number generator, Random card generator 
and Random domino generator will help you launch directly into lesson activities without any setup. 
Use these tools, included in the Lesson Activity Toolkit, to provide students with planned or 
unplanned extensions into number and word concepts.

Pull up past lessons whenever review is needed
One of the nice things about regular teaching on an interactive whiteboard is the accessibility of past 
lesson material. Keep lessons well organized so that you can transition smoothly to a review of a 
particular lesson if you see that students are struggling with your current material.

This word building activity uses the Lesson Activity Toolkit’s 
Random letter generator and requires no setup time.
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Create some learning games ahead of time
Make and collect a library of learning games based on the topics you will be covering throughout 
the year. The Lesson Activity Toolkit has an array of templates for popular games and activities 
created in Flash software. Crossword puzzles, matching games, trivia, anagrams, word-guess 
games and more can be easily created by inputting your own lesson content. 

Preparing these types of games requires a little bit of work ahead of time but, having a collection to 
draw upon as a transitional activity or enrichment task is invaluable when the need arises.

Relevant education games or interactive activities are also a powerful and fun way for any age 
group to review material or start a lesson.

Use ready-to-play strategy games
To ensure that the game-play in your classroom is relevant to your specific student learning 
outcomes, the majority of the education games included in the Lesson Activity Toolkit require you 
to add your own content. However, several ready-to-play strategy games are also included with the 
Toolkit to aid you with impromptu classroom activities. Soduku, chess and checkers are useful for 
teaching children strategy skills and, if used judiciously, can be an effective enrichment task for 
small groups of students.

Help button 
provides 
instructions on 
how to set up and 
use the activity

Edit button allows 
you to customize 
the activity to 
achieve your 
unique student 
learning 
objectives
92



SMART Notebook Software Training for SMART Board Users Level 2 Learner Workbook
Additional resources
What’s next?

Many resources are available to help you take the use of your SMART hardware and software to 
the next level, including free training materials on the SMART website and a special online 
community for educators.
 93



Additional resources
SMART training and professional development 
SMART’s training and professional development website hosts additional training resources and 
support, including free learning resources, online training sessions and self-paced courses to help 
you effectively use any SMART product. 
Visit http://smarttech.com/us/Resources/Training.

Free learning resources
SMART provides many learning resources free of charge to help you continue your professional 
development and explore new products.

Click Browse all training offerings on SMART’s training and professional development website 
to find a complete selection of product training, including free learning resources. 

Live online training sessions
SMART online training sessions are 30- to 90-minute computer and telephone conferences that 
offer a quick overview of the basics of SMART products. Each session is led by a SMART trainer 
who uses SMART products every day. SMART’s online training sessions are useful as a review and 
they give you an opportunity to ask questions.

Live online sessions support a variety of products, including the following:

•  SMART Board interactive whiteboard

•  SMART Notebook software

•  SMART Classroom Suite

•  SMART Response interactive response system

We are always developing new, live online training offerings. Visit SMART’s training center often to 
learn about the latest sessions. 

Self-paced courses
Access self-paced courses through the SMART Learning Center on a variety of product-specific 
topics such as SMART Notebook and SMART Notebook SE, SMART Response and SMART Sync. 

Visit http://smarttech.com/us/Resources/Training/SMART+Learning+Center
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SMART’s support site
SMART’s support site offers a variety of product support options. Visit SMART’s support site to 
download software, find installation and user's guides, “how-to” and troubleshooting articles, 
solutions for your SMART product and answers to your questions. You can also use SMART’s 
support site to contact technical support and to register your SMART product.

Visit http://smarttech.com/us/Support/Browse+Support.

The SMART Exchange website
The SMART Exchange website is an online community where educators can share resources and 
ideas with other educators worldwide. It is where you’ll find the following resources:

•  Free learning resources for use with SMART products, including content collections, software 
applications and website resources

•  Hundreds of SMART Notebook software lesson activities correlated to state and provincial 
curriculum standards

•  Professional development programs to reward, recognize and support educators

•  Research on the effectiveness of SMART Board interactive whiteboards in learning 
environments

•  Advice for educators about using SMART products, integrating peripherals, mastering grant 
writing and evaluating technology

Visit www.exchange.smarttech.com for more information.
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	3 Attach supporting files to your SMART Notebook software file before class Taking time during a lesson to navigate to files you want to show can be awkward and distracting. Your lesson can lose its momentum and students can lose their focus. To avoi...
	4 Use a consistent layout for lesson pages Using a consistent layout for SMART Notebook pages helps your students know where to look for information and keeps them focused on important content. SMART Notebook software includes several themes that you...
	5 Create lessons that fully involve learners The SMART Board™ interactive whiteboard is more than a teaching tool: it’s a learning tool. Students can use the interactive whiteboard to manipulate objects, complete activities, make notes during bra...
	6 Use the Internet and extra resources to encourage inquiry Store links to relevant websites and additional resources as attachments in your SMART Notebook file. When students are particularly interested in a topic or have a question, these links can...
	7 Engage a variety of learning styles SMART Notebook software includes several tools that enable you to tailor lessons to a variety of learning preferences. Auditory learners will appreciate the sound capabilities. Kinesthetic learners will benefit f...
	8 Record processes, instructions or examples to provide further instruction when needed SMART Notebook software includes a Page Recorder that enables you to record all actions on a SMART Notebook page. Consider recording a process or example to be pl...
	9 Seek lesson activities on the Internet Begin by searching the SMART Exchange™ online community, which offers hundreds of ready-made lesson activities and resources. Download and modify lesson activities to suit the needs of your students.
	10 Collaborate and share resources Keep in regular contact with other educators who are using a SMART Board interactive whiteboard. Share experiences, ideas, challenges, lesson activities and solutions.

	The SMART Exchange online community
	1 List three tips for designing effective lesson activities in SMART Notebook software.
	2 From which website can you download SMART-created lesson activities?
	3 Describe two of the areas in the SMART Exchange.
	1 List three tips for designing effective lesson activities in SMART Notebook software.
	2 From which website can you download SMART-created lesson activities? http://exchange.smarttech.com
	3 Describe two of the areas in the SMART Exchange.
	Structuring and organizing lessons
	How can I make my SMART Notebook files organized and easy to use?


	The Lesson Activity Toolkit
	1 Click the Show additional Gallery actions button in the Gallery tab
	2 Select Check for Updates > Lesson Activity Toolkit. The Lesson Activity Toolkit update wizard appears.
	3 Follow the prompts to install or update the Toolkit

	Title pages and lesson pages
	Page grouping
	1 Open the Page Sorter tab
	2 Press the Groups button
	3 Select Edit Groups. If you have not yet edited the groups in the SMART Notebook file, all pages will be in the default group – Group 1. If you have already edited the groups for this file, the pages are displayed under the appropriate title bars.
	1 Press the Add New Group button. A new group title bar appears and a new blank page appears below it. Every group must include at least one page.
	2 Press the group drop-down arrow and select Rename Group
	3 Type a new name for the group

	Linking
	Attachments
	1 Press the Insert button on the Attachments tab
	2 Select Insert Copy of File
	3 Navigate to and select the file you would like to add and press the Open button
	1 Press the Insert button on the Attachments tab
	2 Select Insert Hyperlink
	3 Type the hyperlink address into the Hyperlink field
	4 Type the text you would like to see in the Attachments list – for example, the website name – into the Display name field
	5 Press OK
	1 Press the Insert button on the Attachments tab
	2 Select Insert Shortcut To File
	3 Navigate to and select the file you would like to add and press the Open button

	My Content
	1 Select the Gallery Actions icon to the right of the search button
	2 Select Add Other Files to My Content to launch the Add to My Content... dialog box
	3 Browse to and select the file you would like to add
	4 Press the Open button. Your file will appear as a thumbnail in the My Content area of the Gallery.
	1 Select the My Content menu arrow or a subfolder menu arrow
	2 Select New Folder. A new folder will appear.
	3 Type a name for this folder
	1 Press the item’s thumbnail in the My Content area
	2 Press the drop-down menu arrow
	3 Select Properties to launch the Gallery Item Properties dialog box
	4 Type the keywords you would like associated with the item. For example, you could type editing and symbol if the Gallery item is an editing symbol you frequently use
	5 Press OK

	Team content
	1 List two ways to use links to improve the structure and organization of a lesson activity.
	2 How do you turn on the Show All Links When Page Opens setting?
	3 How do you move a page from one group to another?
	4 What are the three ways you can attach items to a SMART Notebook file?
	5 Why would you add a keyword to an item in the My Content folder?
	6 What is a team content folder?
	1 List two ways to use links to improve the structure and organization of a lesson activity.
	2 How do you turn on the Show All Links When Page Opens setting?
	3 How do you move a page from one group to another?
	4 What are the three ways you can attach items to a SMART Notebook file?
	5 Why would you add a keyword to an item in the My Content folder?
	6 What is a team content folder?
	Adding style to lesson activities
	How can I create professional-looking lesson activities?


	Properties tab
	1 Press the Properties toolbar button
	2 Press the Properties tab
	3 Select the object, press the object drop-down arrow and select Properties
	1 Solid fill – Select a color from the color palette to fill the object entirely. To access more color options, press the More link.
	2 Gradient fill – This type of fill changes, in a gradual transition, from one color to another. Select a color from each of the two palettes. Select a style (the direction the fill transitions in) from the drop-down list. The object will change on...
	3 Pattern fill – This type of fill fills your object with the pattern that you select from the palette. You can also select foreground and background colors for your pattern by clicking the appropriate links. the palette will adjust using your sele...
	4 Image fill – Select image fill to fill your object with an image file you have stored on your computer. Press the Browse link to locate your image file. The image file will be imported in its original size. If you have large files and would like ...

	Themes
	1 Open the Gallery tab
	2 Select Backgrounds and Themes. The Gallery displays thumbnails of the available themes.
	3 Select the thumbnail of the theme you want to apply
	4 Press the thumbnail’s menu arrow and select Insert in Notebook. The Insert Theme dialog box appears.
	5 Select which pages you would like to apply the theme to
	6 Press OK
	1 Select Format > Themes > Create Theme
	2 Type a name for the theme in the Theme name box
	3 Select the text object that appears in the workspace, and modify the text to your desired default text style for the theme. This text object will not appear in the completed theme.
	4 Modify the workspace to reflect your new theme. You may need to scroll down to set up the entire SMART Notebook page.
	5 Press Save

	Active alignment
	Tables
	1 Press the Table button or select Insert > Table. An eight by eight grid appears.
	2 Select the number of columns and rows that you would like to include in the table by dragging over the cells in the grid
	3 The table appears on the SMART Notebook page

	Lesson pages
	Graphics
	1 Select the object drop-down menu
	2 Select Link
	3 Edit the link location details in the Insert Link dialog box
	4 Select whether to launch the link by clicking the corner icon or the object
	5 Press OK
	1 How do you turn active alignment on?
	2 How do you move a table?
	3 How do you add a cell or table shade?
	4 What’s the difference between a theme and a background?
	5 List four items you can modify in the Properties side tab.
	1 How do you turn active alignment on?
	2 How do you move a table?
	3 How do you add a cell or table shade?
	4 What’s the difference between a theme and a background?
	5 List four items you can modify in the Properties side tab.
	Building interactive lesson activities
	How can I take advantage of the interactive features in SMART Notebook software in my lesson activities?


	Dual Page Display and Pin Page
	Attaching sound
	1 Select the object that you would like to attach a sound file to
	2 Select Sound from the object’s drop-down menu. The Insert Sound dialog box appears.
	3 Type the name of the sound file to attach to the object, or press Browse to locate and select the sound file
	4 Press the Play button if you would like to preview the sound to ensure it is the right file
	5 Select whether you’d like to launch the sound by clicking a corner icon or the object
	6 Press OK. The sound file is now associated with the object and the sound file is saved as a part of the SMART Notebook file.

	Object Animation
	1 Select the object you would like to animate
	2 Open the Properties tab
	3 Select the Object Animation tab
	4 Using the drop-down lists provided, select the animation Type, Direction and Speed
	5 Select the animation timing from the Occurs drop- down list. You can set the animation to take place when you enter the page or when you click the object.
	6 Select how many times the animation repeats from the drop-down list

	Interactive resources from the Lesson Activity Toolkit
	1 Select a pull tab from the Graphics folder or create your own pull tab object
	2 Drag the pull tab onto the work area
	3 Add the pull tab text to the workspace using the text button
	4 Select both the text object and the pull tab (press Ctrl and click on each one)
	5 Select Grouping > Group. The two objects will behave as one object.
	6 Move the pull tab until the text is hidden on the edge of the page
	7 During your lesson, use the pull tab to reveal the hidden text or image by pulling it toward the center of the workspace
	1 How do you turn on Dual Page Display?
	2 How do you attach a sound file to an object?
	3 What are three object animation styles?
	4 What are two ways to add text to a text field in an Adobe Flash activity, game or tool from the Lesson Activity Toolkit?
	5 How do you create a pull tab?
	1 How do you turn on Dual Page Display?
	2 How do you attach a sound file to an object?
	3 What are three object animation types?
	4 What are two ways to add text to a text field in an Adobe Flash activity, game or tool from the Lesson Activity Toolkit?
	5 How do you create a pull tab?
	Integrating rich media into lesson activities
	How can rich media add value to my lesson activities?


	Integrating rich media into lesson activities
	Using your favorite websites
	Page Recorder
	1 Open the Properties tab
	2 Press the Page Recording button
	3 Press the Start Recording button
	4 Complete any actions on the SMART Notebook page that you would like to record
	5 Press Stop Recording


	SMART Recorder
	1 Press the Record button. By default, SMART Recorder records the entire workspace, although you can modify this setting.
	2 Complete the actions you would like to record
	3 Use the Pause and Record buttons throughout the recording as required
	4 Press the Stop button to end the recording
	5 You will be prompted to save the file. Select a location, name the file and press Save.
	6 The Recording Complete dialog box appears, providing details of the recording, including file size and recording time
	7 If you would like to immediately view your recording, check Play Recording
	8 Press OK

	SMART Video Player
	Video Player Settings
	1 Select or deselect the Fade out notes check box
	2 Designate the amount of time (in seconds) that should pass before the digital ink begins to fade and how long it should take to clear the screen
	3 Press OK
	Import images
	1 Select Insert > Picture File. The Insert Picture File dialog box opens.
	2 Locate your picture file
	3 Select Open to import the image into the current SMART Notebook page
	1 Select Insert > Picture From Scanner. The Insert Scanned Picture dialog box opens.
	2 Select a scanner from the list
	3 Press the Scan button
	4 Scan your picture and adjust it as needed, following the instructions provided by the scanner’s software
	5 When the scan is complete, close the dialog box and return to SMART Notebook software


	Importing a file with SMART Notebook Print Capture
	1 In the source application, select File > Print. The Print dialog box opens.
	2 Select SMART Notebook Print Capture from the list of printers
	3 In the Print dialog box, select a page range
	4 Press OK Note: If SMART Notebook software is already open, the pages from the source file are added to the SMART Notebook file after the current SMART Notebook page. If SMART Notebook software is not already open, it will launch.
	1 In the source application, select File > Print. The Print dialog box opens.
	2 Select SMART Notebook Print Capture from the list of printers
	3 Press the Properties button. The SMART Notebook Print Capture Properties dialog box opens.
	4 Select Landscape orientation or Portrait orientation
	5 Press OK
	Lesson development in SMART Notebook software
	How can SMART Notebook software help me to arrange the curriculum into interesting and effective lessons?


	Hands-on practice
	Delivering lessons and leveraging interactive tools
	How can I enhance my delivery of lessons using SMART Notebook software?


	Organization and planning for a sophisticated delivery
	Customizing SMART Notebook software for effective lesson delivery
	Customizing the Floating Tools toolbar

	Customizing the interface in SMART Notebook software
	Presentation tips for delivery on an interactive whiteboard
	Leveraging interactive tools
	Responsive lesson delivery
	Additional resources
	What’s next?
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	SMART’s support site
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